Introduction to NI Multisim & Ultiboard
Software version 14.1

Dr. Amir Aslani

August 2018
Outline

• Design & Simulate an active Low Pass Filter in Multisim
• Learn :
  o AC Sweep
  o DC Sweep
  o Parametric Sweep
• PCB design in Ultiboard
• Create new parts and new footprints
• Generate Gerber Files
Placing components in Multisim

1. Select **Place >> Component**.
2. In the “Select a Component” dialog box, set the interface to the following settings. You have now selected the **Analog** group, and the **OPAMP** family.
3. In the ‘Component Field’ select **LM741CH** or **LM741AH/883**.
4. Click on **OK**.
5. Place the **OPAMP** in your schematic area with a left-click of the mouse.
6. Right click and select ‘Flip vertical’
Placing Resistors

• Select **Place >> Component**.
• In the “Select a Component” dialog box, set the dialog to the following settings circled in red. You have now selected the **Basic** group and the **Resistor** family.
• In the "Component Field" type the value of the resistor – in this case **2K**. Make sure to pick a resistor that has the right footprint.
• Click on **OK**, to place the part.
• Place the resistor in your schematic area with a left-click of the mouse.
• You still return to the Component Selection guide.
• Pick one more resistor by selecting the **Basic** group and the **Resistor** family.
• In the ‘Component Field’ type the value of the resistor – in this case **1K**.
• Click on **OK**, to place the part.
• Place the resistor in your schematic area with a left-click of the mouse.
Placing Capacitors

- Select **Place >> Component**.
- In the “Select a Component” dialog box, select the **Basic** group and the **Capacitor** family.
- In the "Component Field" type the value of the capacitor – in this case **0.08uF**.
- Make sure to pick a capacitor that has the right footprint.
Your design should look like this.
To place the Source

- Go to the right most side of your screen
- Hover mouse over each icon to find “Function Generator”
- Place source.
- Double click on it. Change Amplitude to 1 Vp and Frequency to 10 Hz.
- Right click on source and select ‘Flip horizontal’
- Connect the ground (center lead) to GROUND
- Connect the positive lead (+) to R2
- Alternatively, instead of “Function Generator” we can use an AC Voltage Source (Place → Component → Sources → Signal Voltage Source → AC_Voltage)
Your design should look like this
Finished Wiring (just click the leads)
Adding Rails (DC Power Supply)

- Place >> Component
- Group → Sources
  Family – POWER_SOURCES
  Component VCC
- Place two of these.
- Rename one VEE and set to -5v
- The other should remain VCC at 5v, flip this one vertically
- Connect VCC to lead 7, VEE to lead 4
If it does not look like this, switch to PolySci.
Setting up an Analysis & Simulation:

1. From tool bar click on the Voltage Probe and place it at the output of the OpAmp.

2. To change Probe’s name double-click on the probe, and in the “RefDes” section, rename the probe to “Vout”.
As we said we could have used an **AC voltage source** as well:
Running AC Analysis

1. Under **Simulate**→ **Analyses and Simulation**→ **AC Sweep**

2. In the AC Sweep dialog box:
   - Set start frequency to **1 Hz**
   - Set stop frequency to **100 KHz**
   - Set the “Vertical Scale” to “**Decibel**” → this generates Bode plots (magnitude and phase responses)

3. Select the “**Output**” tab

4. In the “Variables in Circuit” section, select “**V(Vout)**” parameter

5. Click on the **Add** button

6. Click on the **Run** button. You will now see your simulation data
Cut Off Frequency

- A cutoff frequency is a boundary in a system's frequency response at which energy flowing through the system begins to be reduced (attenuated or reflected) rather than passing through.
- This occurs when the output voltage has dropped by $1/\sqrt{2}$ or 0.707 of the maximum output voltage ($20\log(\frac{1}{\sqrt{2}}) = -3.0103$ dB) and the power has dropped by half (1/2)
3dB Cut Off Frequency

To find the LPF cut off frequency, you first need to select your cursors. You can do so by first clicking on the cursor item in your toolbar. The cursors will appear at the top of your Y-axis.

1. Right-click on the green cursor arrow on your Y-axis
2. Select Set Y_Value =>
3. A window pops and shows the current value of the Y-axis (in dB). Subtract 3dB from this and type it in the field and click on OK
4. The cursor jumps to the cut off frequency.
5. You can select Grid by clicking on Grid Icon in Toolbar
- This LPF's cut-off frequency is about 970 Hz
If instead of choosing “Decibel” we choose “Linear” for the vertical axis, the AC simulation produces the following magnitude response.
- In the previous graph the output has a linear magnitude of 2 V at 1 Hz. The cut off frequency as mentioned before will be at the location where the output has dropped to $1/\sqrt{2}$ or 0.707 of its maximum value which in this case is 1.414 V.

- Using cursors and setting "Y_Value =>" to 1.414 will show the cut off frequency of about 970 Hz.
DC Sweep Analysis

• The **DC Sweep** analysis generates output like that of a curve tracer. It performs a series of Operating Point analyses, modifying the voltage of a selected source in pre-defined steps, to give a **DC** transfer curve.

• DC sweep performs a sequence of DC operating point simulations. It increments the voltage or current of a selected source in predefined steps over a range of values.

• **DC Sweep Analysis** is used to calculate a circuits’ bias point over a range of values. This procedure allows you to simulate a circuit many times, sweeping the DC values within a predetermined range. You can control the source values by choosing the start and stop values and the increment for the DC range. The bias point of the circuit is calculated for each value of the sweep.
Multisim performs **DC Sweep Analysis** using the following process:
1. The DC Operating Point is calculated using a specified start value.
2. The value from the source is incremented and another DC Operating Point is calculated.
3. The increment value is added again and the process continues until the stop value is reached.
4. The result is displayed on the **Grapher View**.

**Assumptions:** Capacitors are treated as open circuits, inductors as shorts. Only DC values for voltage and current sources are used.
In this tutorial, we will generate the i-v curve for the 1N4002 diode using Multisim. This will tell us the voltages and currents we can apply to the 1N4002 diode in the lab.

Build the following circuit using 1N4002G diode in Multisim:
Run a DC Sweep with the following settings by going to Simulate » Analyses & Simulation » DC Sweep.

Note: This will sweep the value of voltage source V1 from 0V to 1V in 1mV increments.

a. Source: V1  
b. Start Value: 0V  
c. Stop Value: 1V  
d. Increment: 0.001V

In output tab select diode’s output current, I(D1).
You should have the following typical diode i-v curve

Interpret the results. Use the cursors to determine the voltage when the current equals 50mA.

a. Go to Cursors » Show Cursors to show the cursors.
b. Go to Cursors » Set Y Value >= to set the cursor to a specific Y value (0.05A)
c. Read the corresponding X value, which should be 711.21mV in this case.

Note: This means that there was a voltage drop of roughly 711mV when 50mA was flowing through the diode.
Plot the Reverse Bias Current.

a. The plot above shows the forward i-v characteristic for the diode.

b. To find the reverse i-v characteristic, simply choose a negative start value for the swept voltage.

c. Set the Start Value to -101V and run the simulation again. The graph below should appear.

The reverse i-v characteristic is dependent upon the peak reverse voltage of the specific diode. For the 1N4002, the peak reverse voltage is roughly 100V, which is why -101V was chosen. For another diode, this value will be different. The peak reverse voltage can be found in the specification sheet for any diode.
Parametric Sweep

- The behavior of a circuit is affected when certain parameters in specific components change. With **Parameter Sweep Analysis**, you can verify the operation of a circuit by simulation across a range of values for a component parameter. The effect is the same as simulating the circuit several times, once for each value. You control the parameter values by choosing a start value, end value, type of sweep that you wish to simulate and the desired increment value.

- **Parameter Sweep** analysis allows you to run a series of underlying analyses, such as DC or Transient, as one or more parameters in the circuit is varied for each analysis run. This analysis is more generalized than **DC Sweep**.
Parametric Sweep Simulation of a BJT

In this tutorial, we will discuss how to generate a typical I-V curve for a Bipolar Junction Transistor (BJT) in Multisim. To do this, a DC Sweep simulation will be combined with a parametric simulation.

A Bipolar Junction Transistor (BJT) is a three-terminal non-linear device. Current applied to the base of the transistor ($I_B$) controls the amount of current that will flow from the collector to the emitter ($I_C$).

In order to “turn on” the BJT device, we follow a two-step process:
1. Apply voltage across the Collector-Emmitter terminals ($V_{CE}$).
2. Apply current to the base terminal ($I_B$). Then current ($I_C$) will flow from the collector to the emitter, behaving as a current source.
Plotting a Single I-V Curve for a BJT

Build the following circuit

- By default, the current source ($I_{DC}$) and voltage source ($V_{DC}$) will be named I1 and V1, respectively. Rename them to $I_B$ and $V_{CE}$ as you see in the schematic.
- Make certain that the current source is upwards so current goes “into” the base.
- Set $V_{CE} = 0V$ and $I_B = 10\mu A$.

Run a DC Sweep Analysis to “sweep” $V_{CE}$ from 0V to 10V while $I_B$ pushes 10$\mu A$ into the base of the transistor and observe its effect on $I_C$.
  a. Set the Source to be $V_{CE}$
  b. Start value: 0V
  c. Stop value: 10V
  d. Increment: 0.1V
  e. Select $I_C$ of the transistor as the output

Press Run and you should see the following graph.
Note: This is a single I-V curve for a BJT. The x-axis is the “swept” variable ($V_{CE}$) and the y-axis is the collector current.
Plotting a Family of I-V Curves for a BJT

In the simulation above, $I_B$ was fixed at $10 \mu A$ while $V_{CE}$ was swept. Now we would like to see how the BJT behaves if both $V_{CE}$ and $I_B$ are swept. This is known as a **DC Sweep combined with a Parametric Sweep**, often called a “parametric simulation.” In our case, $I_B$ is the “parameter” we wish to vary while $V_{CE}$ is swept.

1. Using the same circuit from the previous simulation, reopen the DC Sweep Analysis settings.
2. Click the box next to Use source 2 to enable the second parameter $I_B$ and enter these settings.
   a. Set the Source to be $I_B$
   b. Start value: $0 A$
   c. Stop value: $50 \mu A$ ($50e^{-6}$)
   d. Increment: $10 \mu A$ ($10e^{-6}$)
3. Run the simulation and the following graph should appear.
Note: This is called a family of I-V curves for a BJT. The x-axis is still the "swept" variable (\(V_{CE}\)) and the y-axis is still the collector current. However, now there is one I-V curve for each value of \(I_B\) that we specified: 0\(\mu\)A, 10\(\mu\)A, 20\(\mu\)A, 30\(\mu\)A, 40\(\mu\)A, and 50\(\mu\)A.
Now that we learned about different analysis options in Multisim, let us go back to our active low pass filter and use NI Ultiboard to make a PCB for the circuit.

- Before sending the schematic design from Multisim to Ultiboard we must have **Footprint** for all parts. (if parts are not blue, they don’t have a footprint)
- Note: In schematic we must provision Input and Output pins to send a signal to the PCB and to measure the output. You can do this by creating in/out Jack or by using a resistor (explained later)
- Also the Op-amp must have a footprint associated with it
Using Resistor footprint as In/Out pins & Power Rails
• As we mentioned all the **BLUE** color components have a footprint associated with them.

• Here ground is in **BLACK**
  – We must create a jumper pin for it and attach pin 3 of OpAmp to it.

• **We intentionally leave this unchanged, because we want to teach you how to manually route this pin to ground in Ultiboard.**
Now we can transfer Multisim schematic to Ultiboard
Changing Track width
The image shows a software window titled "Group Editor" with multiple tabs including "Net groups," "Part groups," "Bus groups," and "Differential pairs." A pop-up window titled "Change Group Settings" is opened, displaying the following settings:

**Group settings**
- **Units:** mil

**Group Name**
- Name: Thick

**Clearance settings**
- Clearance to traces: 10.000000

**Trace width settings**
- Trace width: 40.000000
- Minimum trace width: 40.000000
- Maximum trace width: 70.000000

**Trace length settings**
- Minimum trace length: 0.000000

The window also includes buttons for "OK," "Cancel," "Apply," and "Help."
Changing tracks from one layer to another
Creating the Board Outline
• Double click Board Outline in PCB Design Toolbox
• Make sure “Enable Selecting Other Objects” is active
• Then click on the YELLOW box around your design to select it
• Now you can adjust this (the board outline) to fit your PCB
Design Rule Check (DRC)
3D View
Placing Mounting Holes
How to Manually Route a Trace

1. Choose a copper layer.
2. Select or enter the desired trace size in the **Draw Settings** toolbar.
3. Choose **Place>>Line**.
4. Click a pad on the board. The net the pad is a part of is highlighted, and the pads in the net are each marked with an X.
5. Make your way to the next pad in the net—remember to avoid parts and other traces. Click to fix the trace to the board each time you change direction.
• Now change Copper Top layer to Copper Bottom layer by highlighting it on Design Toolbox on the lefthand side of the page
• Choose **Place**→**Line** and draw a track connecting the VIA to the desired pin.
• If you remember from earlier in Multisim we left out creating a jumper pin for GROUND
• Here we can manually route pin 3 of the OpAmp to create a ground
• Select Place → Line
• Go on Pin3 and manually create a line (track)
• Route that track to a point on the corner of your PCB
• Add a VIA to the end (this would create a hole so you can solder a wire to it and use it as a common ground)
Creating NEW Parts in Multisim
Creating NEW Footprint in Ultiboard
Select technology

- THT (through hole)
- SMT (surface mount)

Package type

- SOT (small outline transistor)
- TO (transistor outline)
- SO-Gullwing (small outline SOIC, SOP, TSSOP)
- SO-J (small outline J lead)
- PLCC (plastic leaded chip carrier package)
- QFP (quad flat package)
- BGA (ball grid array package)
- SBGA (staggered ball grid array package)
- SIP (single in line package)
- ZIP (zigzag in line package)
Suppose we want to create a footprint for our microcontroller MSP30F1611 from Texas Instrument. From MSP30F1611 data sheet (or manual) we find the packaging is QFP (Quad Flat Package).
Exporting Gerber Files

• To begin generating the PCB files, the settings for each of the various file types will need to be established. The first files needed are the Gerber files which allow the manufacturer to create the basic artwork for each of the layers. From the menu:
  
1. Launch the Export setup window from the menu by selecting **File > Export**.

2. In the Export dialog box select the **Gerber RS-274X** format and NC drill
In the left side of the *Gerber RS-274X properties*, select the following *Available Layers* items:

1. All copper layers (Copper Top, Copper Bottom, etc.)
2. Board Outline
3. Silkscreen Top and Silkscreen Bottom
4. Solder Mask Bottom and Solder Mask Top
5. Drill
6. Drill Symbols
It is important to complete the following steps to finalize export:

• In the *Output units* section select **Imperial (inches)**

• In the *Coordinate format* section, select **integer 2** and **decimal place 4**

• Click **Export** and your selected gerber files will be exported and saved in your designated folder
• Once the save operation is completed, reorganize the files as required by the board manufacturer. Some manufacturers require the files to be zipped into a folder with a simple file naming format with just the layer names for each file type. For instance a file named “SeniorDesignProject - Copper Top.gbr” may need to be changed to “Copper Top.gbr” before sending.
1. The **rep** is a report file listing a summary of the drill sizes and quantities.

2. The **drl** file shows the exact locations of each hole.

3. In addition, there are two Gerber files that are related to PCB drilling. The Drill and Drill Symbols are created when the **Gerber RS-274X** is selected and subsequently these files are used in documentation such as the assembly drawing to verify all hole sizes and drill locations are correct.

4. The **Drill** Gerber file shows round images at each hole with the radius of the image the same as the hole radius. When viewing this layer, the user can observe the hole sizes, locations and relations to other locations on the PCB.

5. The **Drill Symbols** Gerber file has symbols shown for each tool. For example, if there are 5 different holes sizes needed for drilling into the PCB, there will be 5 different symbols on this Gerber layer.
Other open source software

• If the purpose is to create a PCB only (and no simulation is required), you can use other open source software such as

1. **PCB Artist** from Advanced Circuits

2. **Eagle** from CadSoft
References

• **Multisim User Manual:**

• **Ultiboard User Manual:**